
     

Proprietary and Confidential to OSHPD & Infinite Solutions 

 

1 

 

 

 

 

 

 

CALIFORNIA CABG OUTCOMES REPORTING 
PROGRAM 

 

 

USER GUIDE 

BD-CCORP-R1.0-TRG-002 

SEP 10, 2008 

 

 

INFINITE SOLUTIONS INC. 

5 PARK CENTER DR, SUITE #110 

SACRAMENTO, CA- 95825 

916-641-0500 

 



     

Proprietary and Confidential to OSHPD & Infinite Solutions 

 

2 

Table of Contents 

 

Set up and Conventions......................................................................................................................... 4 
The Scope of this tutorial ..................................................................................................................................................4 
Resources: Software, FAQs, and Documentation ......................................................................................................4 
To start the application: .....................................................................................................................................................4 
Conventions used in this tutorial .................................................................................................................................10 
Menus ..................................................................................................................................................................................11 
Selecting command buttons...........................................................................................................................................11 
Entering data......................................................................................................................................................................11 
Using CTRL-key combinations ....................................................................................................................................11 

CCORP Application Menu Bar. ........................................................................................................12 
File ........................................................................................................................................................................................12 
Application .......................................................................................................................................................................12 
Table View........................................................................................................................................................................13 
Window..............................................................................................................................................................................14 
Help .....................................................................................................................................................................................15 

Creating Surgeon Profiles ...................................................................................................................16 
Adding Surgeon to the Surgeon List ...........................................................................................................................16 
Editing a surgeon’s data that exists on the Surgeon List .......................................................................................17 
Deleting a Surgeon’s name from the Surgeon list ...................................................................................................18 

Managing Surgery records..................................................................................................................20 
Creating a new surgery record.......................................................................................................................................20 
About the Surgeries screen ............................................................................................................................................21 
Surgeries window, page two ..........................................................................................................................................24 
Surgeries window, page three ........................................................................................................................................25 
Surgeries window, page four..........................................................................................................................................26 
Using the surgery selector ..............................................................................................................................................27 
The “not in list” message ...............................................................................................................................................28 
Changing the sort order in the surgery selector .......................................................................................................29 
The Table View: viewing data as columns and rows ..............................................................................................30 
Finding records matching specific criteria .................................................................................................................32 

Data Outputs: Reports ........................................................................................................................34 
Types of Reports ..............................................................................................................................................................34 
Printing reports .................................................................................................................................................................35 
Navigating Reports...........................................................................................................................................................35 

Data Outputs: Creating External Files ............................................................................................37 



     

Proprietary and Confidential to OSHPD & Infinite Solutions 

 

3 

Creating an electronic text file to send to OSHPD .................................................................................................37 
Creating an External Text File ......................................................................................................................................39 

Errors and Help ....................................................................................................................................47 
Unexpected Events ..........................................................................................................................................................47 
Red: unallowable data ......................................................................................................................................................47 
Missing, required data......................................................................................................................................................47 
Dates ....................................................................................................................................................................................47 
Unallowable, out of range data .....................................................................................................................................47 
Yellow: unexpected data .................................................................................................................................................47 
Not in list ............................................................................................................................................................................48 
The Help menu .................................................................................................................................................................48 
The FAQ site .....................................................................................................................................................................48 
Infinite Solutions Inc. ......................................................................................................................................................48 

 

 

 

 

 

 

 

 

 

 

 

 

 



     

Proprietary and Confidential to OSHPD & Infinite Solutions 

 

4 

Set up and Conventions 

 

The Scope of this tutorial 
The primary goal of the California CABG Outcomes Reporting Program (CCORP) Database 
application is to enter and maintain information about outcomes of Coronary Artery Bypass Graft 
surgeries.  

Resources: Software, FAQs, and Documentation 

The CCORP software is available free of charge from the Office of Statewide Health Planning and 
Development at (link will be provided in future). 

Starting the application and linking to the data file. 

Once the CCORP application is installed on your computer, it will appear in your Start Menu as 
Start > All Programs > CCORPAPP.  Please refer to the user guide for installation. 

To start the application: 
Click on the CCORPAPP icon on the desktop. 

The application opens the ‘Restoring Links’ screen. 

Figure 1 Restoring Links screen 

 

 

The Application will prompt you to locate the files (Figure 1). 

Figure 2 Prompt to locate data file. 
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Note: The file will be located in C:/CCORPAPP/CCORPEnt. 

 If you don’t know where to find the file, check with your network administrator or IT department.. 

Select the file CCORPEnt, and then click Open. Select CCORPEnt again and click Open.  

The pop up message occurs saying that ‘All links were restored’. 

Figure 3 All links were restored screen 

 

Click on ‘OK’ and the application opens the CCORP opening screen. 

Figure 4 CCORP Splash screen 
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Click on OK when the Wait button turns into OK. The application will invoke the Hospital 
Information window. 

Application set up for a hospital. 

Before you can enter any patient data, you’ll need to enter your hospital information. For this step, 
you’ll need the hospital ID provided by OSHPD. If you don’t know your hospital ID, contact the 
CCORP Data Manager. 

Figure 5 Hospital Information screen 
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1. Enter the ‘Hospital ID’ provided by OSHPD. Hospital ID is the mandatory field. 

2. Enter the remaining information such as Hospital Name, Data Contact, Address details [Refer to 
Hospital Information – sample data screen for details] 

 Note: Hospital ID is the only mandatory field. Even though rest of the fields is optional fields 
OSHPD recommends entering all the information. 

Figure 6 Hospital Information- sample data screen 

 

Click Save. The application will display CCORP Menu bars. In the CCORP application, nearly all 
functions are found under the Application menu. (Figure 7) 
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Figure 7 Application Menu  

 

To enter the surgeries window, click on Application > Surgery File. 

The surgeries screen is displayed as shown in Figure 8. 

Figure 8 Surgeries Screen 
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If all the buttons are visible at the bottom of the screen, click Close, then quit the application by 
selecting File > Exit and clicking Yes. If you can’ t  see the buttons at the bottom of the screen, 
you’ll need to adjust your monitor’s resolution.  

To adjust your Monitor’s resolution, quit the application by clicking on Close button or the X 
button. Then select File > Exit and click Yes. 

For Windows XP and Windows Vista, right-click on the blank area of desktop and click on 
‘Properties’. Then click on the settings Tab. (Figure 9) 

For Windows Vista, right-click on the blank area of desktop and click on Personalize. Then click on 
Display Settings. (Figure 9) 
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Figure 9 Display window, settings tab 

 

 

Move the Screen Resolution slider until the resolution displayed is at least 1024 x 768 as illustrated in 
Figure 7.9 

Click on OK. 

Tip [: Changing the screen resolution to higher numbers makes all objects appear smaller. Select 
File > Close or click the close box (X) to close the Display Properties screen. Click on Program files 
-> CCORPAPP to restart the application and verify the screen is properly displayed. 

Conventions used in this tutorial  
Before proceeding, you should be familiar with the conventions used throughout this tutorial to 
describe windows, buttons, menus, and actions. 
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Menus 

The following format is used to refer to selections from the menu: Menu name > Submenu name > 
Sub-submenu name. 

For example, the first exercise in this tutorial asked you to enter your identifying information by 
selecting File > Hospital Information. This instruction means that you should open the File menu 
item and select the item named Hospital Information. 

Selecting command buttons 

In Windows, the various buttons available from on-screen forms are called command buttons. When 
they are referred to in the text, they will appear in bold. 

For example, a reference to a close button might say, “Click the Close button” or simply, “Click 
Close.” 

Entering data 

When you are asked to enter specific data, the data to be entered will be in bold and centered. For 
example: 

Type: Manju Kamalamma 

Then press the Enter key. 

Using CTRL-key combinations 
In Windows, commands can have different effects depending on the context. When you preview 
reports, for example, clicking a printer icon will send the report directly to the printer. Pressing 
CTRL-P, on the other hand, will open the print dialog box where you can select the number of copies, 
change printers, select a specific print tray, or set other printer parameters. When you need to use a 
control-key combination, the command will appear in upper-case, for example CTRL-P (for the 
print command). 
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CCORP Application Menu Bar. 

 
The CCORP Application has five different tabs.  For us to use the software at ease and to save time, 
we are going to see each of the five tabs in detail in this chapter. 
 

File 
The File menu has Page Setup, Print, Links, Hospital Information, Opening Screen, System Status 
and Exit options. 
 

1. If the user needs to Update, Change or Check links, the user goes to File>Links and then 
clicks on the appropriate option.  

 
Figure 10   File menu 
 

 
 

2. If at any time the user needs to update the Hospital Information, the user goes to 
File>Hospital Information and then updates the information. 

 

Application 
The Application tab contains shortcuts to go to Surgery File, Surgery Table View, Reports, Surgeon 
List, Send To OSHPD, Text File and Compact. 
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Figure 11  Application menu 
 

 
 

1. The user can open the Surgeries window anytime by going to Application>Surgery 
File. 

2. To display the data in a spreadsheet format the user can click on Application>Surgery 
Table view. 

3. To generate reports, the user can click on Application>Reports. 
4. To Manage the list of Surgeons the user can click on Application>Surgeon List. 
5. To create an electronic text file to send to OSHPD the user can click on Application> 

Text File. 
6. The user can also compact the database by clicking on Application>Compact. 

 

Table View 
This tab contains all the functions for sorting or filtering the list of surgeries in the surgeries table. 
The user can open the table view of surgeries by either clicking on Application>Surgery Table View 
or by clicking on the ‘Table view’ on the surgeries window. The user then clicks on any cell of the 
table for the ‘Table View’ Menu to become active. The user then uses the required function by 
clicking on it. 
 
Figure 12  Table View Menu 
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Window 
 

There maybe a need for the user to open more than one report at a time. The ‘Window’ tab in the 
menu bar helps the user to manage and display the opened reports.  

 
The reports can be displayed by 

1. Horizontal tiles 
2. Vertical Tiles 
3. Cascade 
4. Arrange by Icons 

 
Figure 13  Window Menu  
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Help 
 

The Help menu contains the links to the OSHPD’s CCORP Site, CCORP User Guide, CCORP 
Quick Guide and CCORP Data Warnings and Errors. 

 
All these documents can be downloaded from Help>About Infinite Solutions Inc. or   
www.4infinitesolutions.com. Also if you have any questions or need help you can contact Infinite 
Solutions. 
 
Figure 14 Help Menu 
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Creating Surgeon Profiles 
In this chapter users will learn how to ‘Add a Surgeon to the Surgeon List’, ‘Edit a Surgeon’s data 
that exists on the Surgeon List’ and to ‘Delete a surgeon’s name from the Surgeon’s List’ of your 
Hospital.  

Adding Surgeon to the Surgeon List 
Select the Surgeon list from the Application tab. Select Application > Surgeon list. The application 
will invoke the Surgeon list screen. 

Figure 15 Surgeon List screen 

 

Click on Add to add a new surgeon to the records. The application invokes the Add Surgeon screen  

Figure 16 Add Surgeon screen 

 

Enter the Last Name First and then the First name in the next field. Enter the Middle Initial If 
available. Enter the CA License No. for the surgeon. Valid CA License Nos. are A, C, G, AFE, 
CFE, GFE followed by 5 numbers. 

Note: Surgeon’s First name, Last Name, and CA License No. fields are mandatory. 

To move to the next field, click TAB or ENTER… 
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Figure 17 Add Surgeon, sample  

 

Editing a surgeon’s data that exists on the Surgeon List 
Select the Surgeon list from the Application tab by clicking on Application > Surgeon list. The 
application will open the Surgeon list window.  

Figure 18 Sample Surgeon list 

 

Select the Surgeon’s name that needs to be edited and then click on Edit. The application invokes 
the Edit Surgeon screen.  

Figure 19 Edit Surgeon screen 

 

Update the Surgeon’s data and click on Save. The Surgeon list gets updated. 
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Figure 20 Updated Surgeon list 

 

Deleting a Surgeon’s name from the Surgeon list 
Select the Surgeon list from the Application tab. Select Application > Surgeon list. The application 
will invoke the Surgeon list screen. Pl. see figure 21. 

Figure 21 Sample Surgeon list 

 

Select the Surgeon’s name that needs to be edited and then click on Edit. The application invokes 
the Edit Surgeon screen. 

Figure 22 Edit Surgeon sample screen 
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Click on the Delete button. The application invokes the ‘Delete Surgeon?’ screen. 

Figure 23 Delete Surgeon confirmation  

 

Click Yes. 

The Application displays a confirmation message that the surgeon was deleted. 

Figure 24 Surgeon deleted message 

 

Click on OK and the Surgeon list gets updated. 
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Managing Surgery records 
In this chapter we will review on how to create a new surgery record, edit an existing surgery record 
and delete a surgery record. The CCORP Surgeries window contains all the information about a 
particular surgery. The Surgeries window consists of four tabs or pages.  

Creating a new surgery record 
1. Invoke the application by selecting Start > All Programs > CCORPAPP. 

2. Once the Hospital Information is entered, the application by default invokes the Surgeries screen 
(Figure 11). 

3. Click New on the surgeries screen to invoke ‘Add New Surgery screen’. (Figure 25)  

Note: If “No Hospital ID Number” message gets displayed, stop and complete the steps beginning 
on page 7 for setting up the application for the hospital. When the user completes the set-up, click 
on Close and the application will return to the Surgeries screen. 

Figure 25 Add new surgery screen  

 

4. Enter the MRN Number. For ex: CBG123344455 

5. Press TAB or ENTER to move to the first Surgery Date field (month). 

6. Enter Date of Surgery 

Note: User must always enter the date in mm/dd/yyyy format. 

12. Click on Save. The Surgeries screen now invokes with all fields and buttons activated. 
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Figure 26 Sample Surgeries screen 

 

About the Surgeries screen 

The Surgeries window consists of four tabs or pages that contain: 

• Fields for data entry, 

• The surgery se l e c tor  (the drop-down list at the bottom of the window) used for moving from one 
record to another, 

• The dele te  button for deleting records from the database, 

• The f ind button for finding records based on general criteria, 

• The res tore  button for discarding any changes that have been made but not saved, 

• The next and previous record buttons, 
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• The se l e c t ion sort order check boxes for sorting the drop-down list by Patient MRN or Surgery date, 

• The new button for creating a new surgery record, 

• The save button for saving changes to the surgery record, 

• The c lose  button for closing the Surgeries window, and table v i ew button for viewing the surgery 
records in a row-and-column format like that used in spreadsheets.  

In the CCORP application, required fields are indicated by a red background if the field is empty or 
the data is not valid (Figure 20). If the required fields are not completed, the state (OSHPD) will not 
consider the record to be complete and you will be required to complete the information and re-
submit the data. There are ten required fields: 

1. MRN 

2. Date of Surgery 

3. Surgeon 

4. Date of Discharge 

5. Discharge Status 

6. Sex 

7. Isolated CABG 

8. Status of Procedure 

9. Dialysis  

10. Prior Percutaneous Coronary Intervention 

In Figure 20, however, you’ll notice that only six fields are pink: Responsible Surgeon Name, 
Isolated CABG, Discharge Date, Discharge Status, Sex and Status of Procedure. As you enter data 
in required fields, the field reverts to white. When you create a surgery record, you must enter an 
MRN and a surgery date in the Add New Surgery window. Thus, when you first see a record in the 
Surgery window, the first two required fields have already been completed.  

 

 

The Surgeries window: Page One 
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Page one of the Surgeries window (Figure 20) contains the identifying information like 
Demographic, Date of Discharge, Discharge Status as well as some of the information about the 
surgical procedure like Operative and Valve Surgery. 

1. Click in the Responsible Surgeon’s name field and click on the drop arrow. Pick a surgeon from 
the drop down list you created, by clicking on the name. 

     Ex: Manju Kamalamma 

Note 

If a new Surgeon’s name needs to be added to the surgeon list click on Add and follow the steps on 
adding a new surgeon on page 12.For adding a new surgeon to the list, repeat step # 1 above. 

Remember to press TAB or ENTER to move from one field to the next. 

2. Click Save.  

Now that you have a few entries, you can use the surgery selector to move from one record to 
another. 

Figure 27 Page One of the Surgeries window 
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Surgeries window, page two 

Page two of the Surgeries window contains the fields related to Comorbidity/Other and Cardiac risk 
factors, as well as the required field Dialysis.  

To go to the next page, click the page tab (Figure 28). 

Figure 28 Page Two of the Surgeries window 
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Note:  

Press the CTRL-SHIFT-TAB key to move backwards (in this case, back to Page One).                
Press the CTRL-TAB to move forwards (in this case, to Page Two).                                                 
The primary fields (MRN, Surgery Date, Surgeon, License Number, and Notes) are displayed on all 
pages. The tool-tip for each field is displayed for all pages.                                                                                                                                   
Command functions (controls) displayed on all pages. 

Surgeries window, page three 

Page three of the Surgeries window contains fields related to Previous Intervention and 
Hemodynamic Status risk factors. This page also contains one of the required fields: Prior 
Percutaneous Coronary Intervention. (Figure 29) 

Figure 29 Page Three of the Surgeries window 
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Surgeries window, page four 

Page four of the Surgeries window contains fields related to Process of Care and Complications. 
(Figure 30) .Page four also contains a conditional field: CPB Utilization-Combination. This field is 
enabled only if you select Combination in the field CPB Utilization. 
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Figure 30 Page Four of the Surgeries window 

 

Using the surgery selector 

At the bottom of the window (to the right of the word “Select”) is a drop-down list called the 
‘Surgery Selector’. The surgery selector lists all records in the database and displays both the MRN 
and the surgery date. 

Open the surgery selector at the bottom of the window by clicking its dropdown arrow (to the left 
of “MRN”), as in Figure 31 
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Figure 31 Surgery selector 

 

2. Click the last entry in the surgery selector (the one for MRN JAC123455676). 

Notice that the window is immediately updated to show the data for that entry.  

Tip: Use the surgery selector to move from one record to another and to sort the list by either 
MRN or surgery date.  

The “not in list” message 

If you type into the surgery selector a number that does not already exist in the database, you’ll 
receive the message in Figure 32. Click OK and then retype the correct number. 
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Figure 32 ‘Not in list’ Message 

 

Note: If you still get the “Not in list” message, it means you have not yet entered the surgery 
information. Rule: Use the surgery selector to select an existing surgery record. Click New to create a 
new surgery record. 

Try it: 

1. Open the drop-down surgery selector to display the records you have entered so far 

2. Double-click to select all the text in the surgery selector. 

3. Type: 

Ex: 77777 

4. Notice that the surgery selector doesn’t select a new record because the number you have entered 
does not match any existing records. 

5. Press ENTER. The application will display the message in Figure 18, above. 

6. Click OK. 

7. Open the surgery selector and select any record in the list. 

Changing the sort order in the surgery selector 

1. In some cases, you may want to view all surgeries performed on a specific date. In that case, you 
would change the sort order of the surgery selector to display records in order of their surgery dates.  

2. Select the last entry displayed. Notice that the MRN and Surgery Date at the top of the window 
change as soon as you select the record. By default, the surgery selector displays entries in order of 
MRN, but you can change the sort order. 

3.  If you sort by surgery date, the application will display the earliest surgery date first. Select 
(check) the Date check box to list the records by surgery date. Open the surgery selector again and 
notice that the list has changed (Figure 26).  

4. Select (check) the MRN check box to return the surgery selector to sorting by MRN. 
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 Figure 33 Viewing the surgery list sorted by date  

 

                                                                              

Tip: In drop-down lists, you can use the mouse to click on an entry, use type-ahead to select an 
entry, or use the up and down arrow keys to select the entry. For the most part, when you use the 
CCORP software, you’ll use the surgery selector to move from one record to another. You can also 
use the next and previous buttons, however, to move among records. These buttons function just 
like those in your Internet browser. The next button (>) will take you to the next record, while the 
previous button (<) will take you to the previous record.  

The Table View: viewing data as columns and rows 
In addition to the Surgeries window, which lists the details of one surgery at a time, the CCORP 
application provides a table view that lists the records as rows and the fields as columns. This view is 
similar to the way data is displayed in spreadsheet applications. In the table view, you can find 
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records based on the data in a specific field (column), you can sort the records by specific fields, and 
you can filter the data so that the application displays only records that meet specific criteria. You can 
open the Table View of the data from either the File menu (Application >Surgery Table View) or 
from the Surgery window, using the Table View button . 
1. Click Table View to display the data in a spreadsheet format (Figure 34).  
 

Figure 34Surgeries table view window 

 
 
2. Click in the Surgery Date field for any record. 
3. Right-click in the same field. Notice that a new pop-up menu becomes available in the table view 
window (Figure 35): 
 
Figure 35 Pop up Menu window 
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When you have the table view open, you can use this menu to find specific entries, filter the records 
so that only records with specific data are displayed, clear or remove the filters, or sort on a specific 
field. Using the menu, you can also freeze or unfreeze columns, which are useful if you want a 
specific column (say, MRN or Date of Surgery) to remain visible as you scroll through the fields to 
the right.  
4. Press ESC to close the pop-up menu. In the next step, you’ll see that, while you can click in a 
field, you cannot enter new data or change existing data. 
5. Click in any field (column) and type: 

123 
6. Notice that typing has no effect on the data in table view. All changes or additions to the data must 
be made in the Surgeries window. 
7. Click on a record (row) from your list of MRN. 

8. Click Show. The table view window closes and the application opens the Surgeries window. 

Finding records matching specific criteria 
In some cases, you may want to find all entries matching specific criteria, such as all surgeries 
performed by a specific surgeon, or all male patients. Using the Find function, you can search for 
entries that meet the following criteria: 
• Date of surgery 
• Date of discharge 
• Surgeon 
• Date of birth 
• Age 
• Gender 
• Race, and 
• Discharge status. 

In addition to finding entries matching one specific field (such as surgeon), you can combine the 
criteria by entering values for more than one field. 
  
To review the Find function: 
 
1. If the Surgeries window is not already open, open it by selecting Application >Surgery File. 
2. Click Find to open the Find Surgery window (Figure 36). 
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Figure 36 Find Surgery window 

 

3. Select the criteria by which the surgery record needs to be founded as shown in Figure 36. 
4. Click close after finding the record. The Surgeries screen opens for the record displayed in the 
Selector field. 
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Data Outputs: Reports 
Reports are, essentially, anything that can be printed. The CCORP application includes reports for 
missing data, physician certifications, and summaries of surgery statistics, and a detail record for 
each surgery. For several of these reports, you can set date ranges so that only a specific period is 
included in the report. 

Types of Reports 
The CCORP application contains the following reports: 

• List of Surgeries, All Surgeons 
• List of Surgeries, by Selected Surgeon 
• Missing Data, All Patients 
• Patient Surgery Detail, All Patients 
• Patient Surgery Detail, by Selected MRN and Surgery Date 
• Patient Surgery Detail, by Selected Surgeon 
• Semi-Annual Hospital Certification 
• Semi-Annual Physician Certification, All Surgeons 
• Semi-Annual Physician Certification, Selected Surgeon by Period 
• Surgery List by CABG and Discharge Status, All Surgeons 
• Surgery List by CABG and Discharge Status, by Selected Surgeon 

 
1. From the menu, select Application > Reports. The application opens the Standard Reports 
window (Figure 37). 
 
Figure 37 Standard Reports window 
 

 
 
2. Open the drop-down reports list (Figure 38). 

 

 

 

Figure 38 Reports drop-down list window 



     

Proprietary and Confidential to OSHPD & Infinite Solutions 

 

35 

 

3. Click the report in the list named “Missing Data, All Patients.” 
4. Click Preview. 
5. Click once on the report to see the entire report in the window. 
6. Press ESC to close the report. 
7. Open the Standard Reports window again by selecting Application > Reports 
8. Open the drop-down reports list and select “Patient Surgery Detail, All Patients.” Notice that you 
can now enter a date range for surgeries to be included in the report. You haven’t entered any 
discharge data yet, so the report has nothing to print. Later in the tutorial, when you have entered 
some surgery information, you’ll print the report and practice entering data ranges for reports like 
these. 
9. Click Close. 

Printing reports 
There are two methods of printing reports: selecting File > Print or pressing CTRL-P. The two 
methods have markedly different results. 
• Selecting File > Print from the menu immediately sends the report to the default printer and prints 
one copy. 
• Pressing CTRL-P opens the print dialog window where you can select a different printer (if 
available), set the number of copies to be printed, and make other changes such as the page 
orientation (portrait or landscape) and the like. 

Navigating Reports 
When a report first opens, you see only the first page. To see other pages (if there are other pages), 
use the report navigation buttons at the bottom of the window. (Figure 39) 
 
 
 
 
 
 
 
Figure 39 Navigating Reports window 
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To move to a specific page in the report, type the number in the page number area and press 
ENTER. You can also click on the arrow to go to the next page. 
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Data Outputs: Creating External Files 
The CCORP application can create two types of external files: (1) a Microsoft Office Excel Comma 
Separated Values File submission to OSHPD, and (2) a text file for which you can select specific 
fields and specific types of records to be included. The OSHPD export file has a file-name extension 
of “.csv”. The file produced by the “Text File” function has a file-name extension of “.txt” and can 
be used to analyze CCORP data in statistical analysis applications. 

Creating an electronic text file to send to OSHPD 
Creating a file to submit to OSHPD is a very simple process. Select the six-month period to be 
included in the file and note the name of the exported file. The drop-down list will display only the 
periods for which records are available. 
  
1. From the menu, select Application > Send to OSHPD to open the export window (Figure 40). 
 
Figure 40 Send file… window 
 

 
 
2. Open the drop-down list to select the period to include in the export file (Figure 41). 
 
Figure 41 selecting a period to send file … window 
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3. Select any period. The surgeries are grouped into 6 month periods by discharge dates. 

4. Note the number of records to be included for a period in the file (Figure 42). 

Figure 42 Found records indicator 

 

5. Click Create. When the export is finished, the export window will indicate the number of records 
included in the export file (Figure 43). 
 
Figure 43 File export completed message 
 

 
 
6. Click OK. 
7. The application displays the Send File to OSHPD window with the location and name of the 
export file (Figure 37). 
8. Note the name of the file in C:\CCORPOSHPD. 

9. If you want to keep a record of the file location, click Print. The application will print the screen 
exactly as it appears; the Print button sends the document directly to the printer. 

10. Click Close. 

11. Copy the file in C:\CCORPOSHPD\ to a floppy disk, Zip disk or CD and send it to OSHPD. 
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Figure 44 Completed export message 
 

 
 

Creating an External Text File 

The external text file produced by the CCORP application is a tab-delimited file consisting of the 
fields and records you select. After you export the file, the application displays a window listing the 
fields contained in the export file. In the following tasks, you’ll create an external text file selecting 
only certain types of patients and only a subset of the fields in the CCORP application. 
To create the external text file: 
1. From the menu, select Application > Text File to open the Create Text File window. 
2. The application will display a warning that the Text File function will not create the correct file to 
send to OSHPD (Figure 45). 
 
Figure 45 Text file warning  
 

 
 
3. Click OK. The application will open the window for creating the text file (Figure 46). 
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Figure 46 Create Text File window when first opened 
 

 
 
4. Notice the two tabs in the window. On the first tab, you can select the type of patients to be 
included in the file. On the second tab, you can select the fields to be included. 
5. Select (check) the Surgeon check box, open the drop-down list, and select MANJU, 
KAMALAMMA. (Figure 46) 
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Figure 46 Selecting a Surgeon 
 

  
 
6. Select the Gender check box, open the list, and select Male. 
7. Select the Discharge Status check box and select Alive. 
8. The Create Text File window should now look like Figure 47. (The number of records found may 
differ, if records have been entered other than those in this tutorial.) 
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Figure 47 Selected surgery and patient characteristics to be included in the text file 
 

  
 
9. Click the Select Fields tab (Figure 48). By default, the text file contains all fields except those you 
exclude. Notice that when the tab first appears, all the fields have been selected for inclusion in the 
text file. The next step, therefore, is to exclude fields. 
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Figure 48 Select fields tab window 
 

 
 
10. Scroll through the bottom list to Date of Birth 
11. Double-click Date of Birth to exclude it. (You’ll keep the age field.) 
12. Double-click Date of Death to exclude it. (Because you selected Alive on the Select Records tab.) 
13. Double-click Date of Discharge to exclude it. 
14. Scroll down to Height and double-click it or type H on your keyboard until you come to Height 
15. Scroll down to Mitral Insufficiency and double-click it. 
16. Scroll up to Left Main Disease(%) 
17. Click once on Left Main Disease(%) and notice the value list displayed in the middle section of 
the window. 
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Figure 49 Displaying the value list for a specific field 
 

 
 
18. Scroll down further in the Fields Selected window and exclude the following fields by double-
clicking them: 
• Record Changed (The “record” fields are administrative fields used by the database. You should 
always exclude them from your exported fields unless you are auditing database use.) 
• Record Entered 
• Record Imported 
• Record Status 
• Surgeon name first 
• Surgeon name last 
• Surgeon name middle initial 
• Weight. 
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19. Move to the top section of the window and double-click Weight to move it back to the list of 
included fields. (Hint: you’ll have to scroll down the list to find it.) 
20. Click Create. The application opens a Save window and offers a default file name of 
CCORP.txt. This is not a particularly informative name, so change the name to indicate the date you 
exported the file using the following format: mmddyyyy. Thus, if you are exporting the file on 
August5,2008, you would name it 080508.txt or in the format Hospital ID_YYYY_Report 
Period.txt. For example 341059_2008_1.txt 
21. For the purposes of this tutorial, select the complete file name and change it to: 
341059_2008_1.Your Save window should now look like Figure 50. 
 
Figure 50 Assigning a name for the text file 
 

 
 
22. Click Save 
23. When the application displays the Export Completed message (Figure 51), click OK 
 
Figure 51 Export Completed window 
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24. The application will then display the Text File Description window (Figure 52). Your 
information may differ depending on when you export the data and the number of records in the 
database at the time. 
 
Figure 52 Text file window description 
 

 
 
25. Click Print. 

26. Click anywhere in the white area of the Text File Description window. Notice that the scroll bars 
are activated and you can select text. 
27. Click the cursor at the beginning of the row reading “Col Field Name Description.”  
28. Holding down the mouse button, drag the cursor down to the end of the window so that you 
have highlighted all the text describing the fields. 
29. Press CTRL-C to copy the text. 
30. Leaving this window open, go to the Start button and select Start > Programs >Accessories > 
Word Pad. 
31. Press CTRL-V or select Edit > Paste to paste the text into this new document. You can now 
save this file in the same folder as the text file you exported. 
32. Exit Word Pad by selecting File > Exit. Save the file if you want to keep a record of this export. 
33. Select CCORP from the task bar to return to the CCORP application. 
34. Click Close to close the Text File Description window. 
35. Click Close to close the Create Text File window. 
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Once you have created an external text file, you can open the file in a spreadsheet program such as 
Excel, a database program, a word processor, or any statistical analysis program that can read text 
files. If your program asks you for the file type, indicate that it is a tab-delimited text file. 
 
 
 
 
 
 
 

Errors and Help 
The best source of information about the CCORP software is the CCORP FAQ page maintained by 
Infinite Solutions at www.4infinitesolutions.com/CCORP. In addition to answers to frequently 
asked questions, this site provides links to the application and data files, as well as all documentation. 
This site is available under the Help menu in the CCORP application. 

Unexpected Events 
Unexpected events generally occur when the CCORP application can’t link or write to the data file 
or to itself. 

Red: unallowable data 

Red error messages indicate invalid data that cannot be saved. Types of invalid date include: 

Missing, required data 

Required fields that have not been completed with have a red background until you enter valid data. 

Dates 

• Dates in the future 

• Dates that conflict with other CCORP dates, such as a discharge date that occurs before a surgery 
date. 

Unallowable, out of range data 
Fields that accepts numerical values (Last Creatinine Level Pre-op, Ejection Fraction, and Left Main 
Disease, % Stenosis), do not accept data that is outside the defined allowable range. If you enter a 
value that is outside the defined range, the application will display an error message. Invalid data 
cannot be saved. Delete the data and enter valid data. 

Yellow: unexpected data 

In addition to allowable ranges, the three fields listed above also have “expected” ranges. If you 
enter data that is outside the expected range, but within the allowable range, the application will 
display a yellow warning message. Unlike unallowable data, unexpected data can be saved, although  
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the field will remain yellow. 

Not in list 

The “not in list” error occurs if you type a value in a field that allows only the entries from the drop-
down list. Delete the typed entry and select a value from the list. The “not in list” error applies to all 
fields that use drop-down lists, including the surgery selector and the surgeon selector. 

The Help menu 
The Help menu in the CCORP application provides links to the main Infinite Solutions CCORP 
FAQ page, as well as pages dealing with specific topics. The Help menu also provides a link to the 
CCORP site maintained by the Office of Statewide Health Planning and Development. 

The FAQ site 
Infinite Solutions Inc. maintains an FAQ page at www.4infinitesolutions.com/CCORPFAQ.html. 
That page contains links to all software and documentation for the CCORP application and 
provides a link to the main CCORP site maintained by the Office of Statewide Health Planning and 
Development.  

Infinite Solutions Inc. 
If you have questions or need help with the CCORP software, feel free to contact Infinite Solutions 
Inc.  at 1-916-641-0500x5. We will be happy to help.  
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